# CVE-2021-3964: Authorization Bypass Through User-Controlled Key in elgg/elgg

> Attackers can bypass authorization controls in Elgg by manipulating user-controlled keys, potentially accessing unauthorized resources.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gwpx-q2h9-wxgx

## What is CVE-2021-3964?

CVE-2021-3964 is a medium-severity authentication bypass vulnerability in elgg/elgg, published on 1 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

elgg is vulnerable to Authorization Bypass Through User-Controlled Key

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2021-3964?

2 open source packages ship an affected version, including elgg/elgg. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elgg/elgg` | Packagist | All versions | 3.3.22 |
| `elgg/elgg` | Packagist | All versions | 3.3.22 |

Products: Elgg Elgg.

## How do I fix CVE-2021-3964?

Upgrade elgg/elgg to 3.3.22 or later.

## Is CVE-2021-3964 being exploited?

There is no known exploitation of CVE-2021-3964 in the wild and no public exploit code.

## Other vulnerabilities in elgg/elgg

- [CVE-2011-2936](https://insights.sbomify.com/CVE-2011-2936/): SQL injection in Elgg (critical 9.8)
- [CVE-2021-4072](https://insights.sbomify.com/CVE-2021-4072/): Cross-site Scripting (XSS) - Stored in elgg/elgg (critical 9.0)
- [CVE-2012-6562](https://insights.sbomify.com/CVE-2012-6562/): Missing authorization in n/a (medium 6.8)
- [CVE-2011-2935](https://insights.sbomify.com/CVE-2011-2935/): Elgg Reflected XSS Vulnerability (medium 6.1)
- [CVE-2019-11016](https://insights.sbomify.com/CVE-2019-11016/): Elgg open redirect (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3964 and fix it if it is affected.

What it is: CVE-2021-3964 is a medium-severity authentication bypass vulnerability in elgg/elgg, published on 1 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3964 in the wild and no public exploit code.

Affected packages and fixed versions:
- elgg/elgg (Packagist): affected all versions; fixed in 3.3.22
- elgg/elgg (Packagist): affected all versions; fixed in 3.3.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3964/ (Markdown: https://insights.sbomify.com/CVE-2021-3964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3964
- OSV: https://osv.dev/vulnerability/CVE-2021-3964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3964/
Summaries are generated and may contain mistakes; the official description above is the record.
