{"answers":{"affected":"2 open source packages ship an affected version, including kevinpapst/kimai2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3985 in the wild and no public exploit code.","fix":"Upgrade kevinpapst/kimai2 to 1.16.3 or later.","what":"CVE-2021-3985 is a high-severity cross-site scripting vulnerability in kevinpapst/kimai2, published on 1 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3985 and fix it if it is affected.\n\nWhat it is: CVE-2021-3985 is a high-severity cross-site scripting vulnerability in kevinpapst/kimai2, published on 1 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-3985 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kevinpapst/kimai2 (Packagist): affected all versions; fixed in 1.16.3\n- kevinpapst/kimai2 (Packagist): affected all versions; fixed in 1.16.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3985/ (Markdown: https://insights.sbomify.com/CVE-2021-3985/index.md)","id":"CVE-2021-3985","markdown":"https://insights.sbomify.com/CVE-2021-3985/index.md","name":"CVE-2021-3985","record":{"aliases":["GHSA-x68c-4gmm-5g43"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Kimai time tracking","requires_auth":"low_privilege","summary":"Stored XSS in Kimai allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"kimai2","vendor":"kimai"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Stored in kevinpapst/kimai2","id":"CVE-2021-3985","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Information Disclosure in janeczku/calibre-web","id":"CVE-2021-3986"},"packages":[{"ecosystem":"Packagist","fixed":["1.16.3"],"introduced":["0"],"last_affected":[],"package":"kevinpapst/kimai2","purl":null,"source":"GHSA-x68c-4gmm-5g43"},{"ecosystem":"Packagist","fixed":["1.16.3"],"introduced":["0"],"last_affected":[],"package":"kevinpapst/kimai2","purl":"pkg:composer/kevinpapst/kimai2","source":"GHSA-x68c-4gmm-5g43"}],"prev":{"headline":"Heap-based Buffer Overflow in vim/vim","id":"CVE-2021-3984"},"products":["kevinpapst/kimai2"],"published":"2021-12-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["kevinpapst"]},"summary":"Stored XSS in Kimai allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2021-3985/"}