# CVE-2021-3985: Cross-site Scripting (XSS) - Stored in kevinpapst/kimai2

> Stored XSS in Kimai allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-x68c-4gmm-5g43

## What is CVE-2021-3985?

CVE-2021-3985 is a high-severity cross-site scripting vulnerability in kevinpapst/kimai2, published on 1 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3985?

2 open source packages ship an affected version, including kevinpapst/kimai2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kevinpapst/kimai2` | Packagist | All versions | 1.16.3 |
| `kevinpapst/kimai2` | Packagist | All versions | 1.16.3 |

Products: Kimai Kimai2.

## How do I fix CVE-2021-3985?

Upgrade kevinpapst/kimai2 to 1.16.3 or later.

## Is CVE-2021-3985 being exploited?

There is no known exploitation of CVE-2021-3985 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3985 and fix it if it is affected.

What it is: CVE-2021-3985 is a high-severity cross-site scripting vulnerability in kevinpapst/kimai2, published on 1 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3985 in the wild and no public exploit code.

Affected packages and fixed versions:
- kevinpapst/kimai2 (Packagist): affected all versions; fixed in 1.16.3
- kevinpapst/kimai2 (Packagist): affected all versions; fixed in 1.16.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3985/ (Markdown: https://insights.sbomify.com/CVE-2021-3985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3985
- OSV: https://osv.dev/vulnerability/CVE-2021-3985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3985/
Summaries are generated and may contain mistakes; the official description above is the record.
