# CVE-2021-39864: Adobe Commerce Cross-Site Request Forgery (CSRF) Could Lead To Unauthorized Cart Addition

> An unauthenticated attacker can exploit a CSRF vulnerability in Adobe Commerce to add items to a customer's cart without authorization.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Oct 2021
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-94wq-87g6-8h77

## What is CVE-2021-39864?

CVE-2021-39864 is a medium-severity vulnerability in Adobe Commerce, published on 15 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Adobe Commerce versions 2.4.2-p2 (and earlier), 2.4.3 (and earlier) and 2.3.7p1 (and earlier) are affected by a cross-site request forgery (CSRF) vulnerability via a Wishlist Share Link. Successful exploitation could lead to unauthorized addition to customer cart by an unauthenticated attacker. Access to the admin console is not required for successful exploitation.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-39864?

8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p2 |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p2 |
| `magento/community-edition` | Packagist | From 2.4.2-p1 to 2.4.2-p2 | None |
| `magento/community-edition` | Packagist | From 2.4.2-p1 to 2.4.2-p2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Commerce, Adobe Magento Open Source.

## How do I fix CVE-2021-39864?

Upgrade magento/community-edition to 2.3.7-p2 or later.

## Is CVE-2021-39864 being exploited?

There is no known exploitation of CVE-2021-39864 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39864 and fix it if it is affected.

What it is: CVE-2021-39864 is a medium-severity vulnerability in Adobe Commerce, published on 15 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-39864 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p2
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p2
- magento/community-edition (Packagist): affected from 2.4.2-p1 up to 2.4.2-p2; no fix listed
- magento/community-edition (Packagist): affected from 2.4.2-p1 up to 2.4.2-p2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39864/ (Markdown: https://insights.sbomify.com/CVE-2021-39864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39864
- OSV: https://osv.dev/vulnerability/CVE-2021-39864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39864/
Summaries are generated and may contain mistakes; the official description above is the record.
