# CVE-2021-3988: Cross-site Scripting (XSS) in janeczku/calibre-web

> Attackers can execute arbitrary JavaScript via unsanitized input in book editing features, potentially stealing cookies.

- **Severity:** Medium 5.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2024
- **Updated:** 20 Nov 2024
- **Also known as:** GHSA-r735-9gc6-2hvq, PYSEC-2026-1236

## What is CVE-2021-3988?

CVE-2021-3988 is a medium-severity cross-site scripting vulnerability in janeczku/calibre-web, published on 15 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A Cross-site Scripting (XSS) vulnerability exists in janeczku/calibre-web, specifically in the file `edit_books.js`. The vulnerability occurs when editing book properties, such as uploading a cover or a format. The affected code directly inserts user input into the DOM without proper sanitization, allowing attackers to execute arbitrary JavaScript code. This can lead to various attacks, including stealing cookies. The issue is present in the code handling the `#btn-upload-cover` change event.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3988?

3 open source packages ship an affected version, including calibreweb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `calibreweb` | PyPI | All versions | 0.6.15 |
| `calibreweb` | PyPI | All versions | 0.6.15 |
| `calibreweb` | PyPI | All versions | 0.6.15 |

Products: Janeczku Calibre-Web.

## How do I fix CVE-2021-3988?

Upgrade calibreweb to 0.6.15 or later.

## Is CVE-2021-3988 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3988 exists.

## Other vulnerabilities in janeczku/calibre-web

- [CVE-2022-30765](https://insights.sbomify.com/CVE-2022-30765/): SQL injection in calibreweb (critical 9.8)
- [CVE-2020-12627](https://insights.sbomify.com/CVE-2020-12627/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2022-0990](https://insights.sbomify.com/CVE-2022-0990/): Server-Side Request Forgery (SSRF) in janeczku/calibre-web (critical 9.3)
- [CVE-2022-0767](https://insights.sbomify.com/CVE-2022-0767/): Server-Side Request Forgery (SSRF) in janeczku/calibre-web (critical 9.1)
- [CVE-2022-0939](https://insights.sbomify.com/CVE-2022-0939/): Server-Side Request Forgery (SSRF) in janeczku/calibre-web (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3988 and fix it if it is affected.

What it is: CVE-2021-3988 is a medium-severity cross-site scripting vulnerability in janeczku/calibre-web, published on 15 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3988 exists.

Affected packages and fixed versions:
- calibreweb (PyPI): affected all versions; fixed in 0.6.15
- calibreweb (PyPI): affected all versions; fixed in 0.6.15
- calibreweb (PyPI): affected all versions; fixed in 0.6.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3988/ (Markdown: https://insights.sbomify.com/CVE-2021-3988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3988
- OSV: https://osv.dev/vulnerability/CVE-2021-3988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3988/
Summaries are generated and may contain mistakes; the official description above is the record.
