CVE-2021-39880 apollo_upload_server has Denial of Service vulnerability

Medium 6.5 Published Updated

An attacker can cause a denial of service in GitLab by sending specially crafted requests to the apollo_upload_server middleware.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39880?

CVE-2021-39880 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 5 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to deny access to all users via specially crafted requests to the apollo_upload_server middleware.

Which versions are affected by CVE-2021-39880?

3 open source packages ship an affected version, including gitlab and apollo_upload_server. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.9.014.0.9, 14.1.4, 14.2.2
apollo_upload_server RubyGemsAll versions2.1.0
apollo_upload_server RubyGemsAll versions2.1.0

Products include Gitlab Gitlab.

How do I fix CVE-2021-39880?

Upgrade gitlab to a fixed version for your release line: 14.0.9, 14.1.4 or 14.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-39880 being exploited?

There is no known exploitation of CVE-2021-39880 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39880, DEBIAN-CVE-2021-39880, GHSA-w6pv-c757-6rgr, UBUNTU-CVE-2021-39880.

Is CVE-2021-39880 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free