CVE-2021-39885 Cross-site scripting in GitLab

High 8.7 Published Updated

Stored XSS in GitLab EE allows attackers to execute arbitrary JavaScript via malicious approval rule names, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-39885?

CVE-2021-39885 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 4 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A Stored XSS in merge request creation page in all versions of Gitlab EE starting from 13.7 before 14.1.7, all versions starting from 14.2 before 14.2.5, and all versions starting from 14.3 before 14.3.1 allows an attacker to execute arbitrary JavaScript code on the victim's behalf via malicious approval rule names

Weakness: CWE-79

Which versions are affected by CVE-2021-39885?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.7.014.1.7, 14.2.5, 14.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2021-39885?

Upgrade gitlab to a fixed version for your release line: 14.1.7, 14.2.5 or 14.3.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-39885 being exploited?

There is no known exploitation of CVE-2021-39885 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39885, GHSA-cvqc-8rrv-whf2, UBUNTU-CVE-2021-39885.

Is CVE-2021-39885 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free