CVE-2021-39886 Missing authorization in GitLab
Attackers can read confidential Epic references by moving issues between projects due to missing permission checks in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-39886?
CVE-2021-39886 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 5 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Permissions rules were not applied while issues were moved between projects of the same group in GitLab versions starting with 10.6 and up to 14.1.7 allowing users to read confidential Epic references.
Weakness: CWE-276
Which versions are affected by CVE-2021-39886?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 10.6.0 | 14.1.7, 14.2.5, 14.3.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-39886?
Upgrade gitlab to a fixed version for your release line: 14.1.7, 14.2.5 or 14.3.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-39886 being exploited?
There is no known exploitation of CVE-2021-39886 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-39886, GHSA-cxfj-qcv7-fx7w, UBUNTU-CVE-2021-39886.