CVE-2021-39887 Cross-site scripting in GitLab

High 7.3 Published Updated

An attacker can execute arbitrary JavaScript on victims via stored XSS in GitLab Flavored Markdown, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-39887?

CVE-2021-39887 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 5 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A stored Cross-Site Scripting vulnerability in the GitLab Flavored Markdown in GitLab CE/EE version 8.4 and above allowed an attacker to execute arbitrary JavaScript code on the victim's behalf.

Weakness: CWE-79

Which versions are affected by CVE-2021-39887?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.4.014.1.7, 14.2.5, 14.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2021-39887?

Upgrade gitlab to a fixed version for your release line: 14.1.7, 14.2.5 or 14.3.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-39887 being exploited?

There is no known exploitation of CVE-2021-39887 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39887, GHSA-8j2x-wq4x-63v8, UBUNTU-CVE-2021-39887.

Is CVE-2021-39887 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free