CVE-2021-39890 Auth bypass in GitLab

Low 3.1 Published Updated

Attackers can bypass two-factor authentication for LDAP users using Basic Authentication to access restricted pages in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39890?

CVE-2021-39890 is a low-severity authentication bypass vulnerability in Gitlab Gitlab, published on 6 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

It was possible to bypass 2FA for LDAP users and access some specific pages with Basic Authentication in GitLab 14.1.1 and above.

Weakness: CWE-287

Which versions are affected by CVE-2021-39890?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.1.114.1.7, 14.2.5, 14.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2021-39890?

Upgrade gitlab to a fixed version for your release line: 14.1.7, 14.2.5 or 14.3.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2021-39890 being exploited?

There is no known exploitation of CVE-2021-39890 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39890, GHSA-45jj-6gxc-rh25, UBUNTU-CVE-2021-39890.

Is CVE-2021-39890 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free