CVE-2021-39904 Missing authorization in GitLab

Medium 4.3 Published Updated

A Merge Request creator can bypass locks to resolve discussions and apply suggestions, allowing unauthorized modification of locked merge requests.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39904?

CVE-2021-39904 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 4 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An Improper Access Control vulnerability in the GraphQL API in all versions of GitLab CE/EE starting from 13.1 before 14.2.6, all versions starting from 14.3 before 14.3.4, and all versions starting from 14.4 before 14.4.1 allows a Merge Request creator to resolve discussions and apply suggestions after a project owner has locked the Merge Request

Weakness: CWE-863

Which versions are affected by CVE-2021-39904?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.1.014.2.6, 14.3.4, 14.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2021-39904?

Upgrade gitlab to a fixed version for your release line: 14.2.6, 14.3.4 or 14.4.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2021-39904 being exploited?

There is no known exploitation of CVE-2021-39904 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39904, GHSA-2mm8-x5g7-wf73, UBUNTU-CVE-2021-39904.

Is CVE-2021-39904 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free