CVE-2021-39906 Cross-site scripting in GitLab

High 8.7 Published Updated

An attacker can execute arbitrary JavaScript code on a victim's behalf via improperly validated ipynb files in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-39906?

CVE-2021-39906 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 4 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Improper validation of ipynb files in GitLab CE/EE version 13.5 and above allows an attacker to execute arbitrary JavaScript code on the victim's behalf.

Weakness: CWE-79

Which versions are affected by CVE-2021-39906?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.5.014.2.6, 14.3.4, 14.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2021-39906?

Upgrade gitlab to a fixed version for your release line: 14.2.6, 14.3.4 or 14.4.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-39906 being exploited?

There is no known exploitation of CVE-2021-39906 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39906, GHSA-6cxq-rcp9-rqr8, UBUNTU-CVE-2021-39906.

Is CVE-2021-39906 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free