CVE-2021-39908 Code injection in GitLab

Medium 6.5 Published Updated

Attackers can inject malicious code into GitLab projects using Unicode characters that bypass UI visibility checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39908?

CVE-2021-39908 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 1 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In all versions of GitLab CE/EE starting from 0.8.0 before 14.2.6, all versions starting from 14.3 before 14.3.4, and all versions starting from 14.4 before 14.4.1 certain Unicode characters can be abused to commit malicious code into projects without being noticed in merge request or source code viewer UI.

Weakness: CWE-94

Which versions are affected by CVE-2021-39908?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 0.8.014.2.6, 14.3.4, 14.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2021-39908?

Upgrade gitlab to a fixed version for your release line: 14.2.6, 14.3.4 or 14.4.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2021-39908 being exploited?

There is no known exploitation of CVE-2021-39908 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39908, GHSA-hm25-53gr-mc5r, UBUNTU-CVE-2021-39908.

Is CVE-2021-39908 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free