# CVE-2021-39913: Information disclosure in GitLab

> An attacker with local file access can read the system root password from migration logs, leading to privilege escalation.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-gitlab-2021-39913, GHSA-hw95-w73v-wf42, UBUNTU-CVE-2021-39913

## What is CVE-2021-39913?

CVE-2021-39913 is a medium-severity vulnerability in Gitlab Gitlab, published on 4 Nov 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Accidental logging of system root password in the migration log in all versions of GitLab CE/EE before 14.2.6, all versions starting from 14.3 before 14.3.4, and all versions starting from 14.4 before 14.4.1 allows an attacker with local file system access to obtain system root-level privileges

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2021-39913?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | All versions | 14.2.6, 14.3.4, 14.4.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2021-39913?

Upgrade gitlab to a fixed version for your release line: 14.2.6, 14.3.4 or 14.4.1.

## Is CVE-2021-39913 being exploited?

There is no known exploitation of CVE-2021-39913 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39913 and fix it if it is affected.

What it is: CVE-2021-39913 is a medium-severity vulnerability in Gitlab Gitlab, published on 4 Nov 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39913 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected all versions; fixed in 14.2.6, 14.3.4, 14.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39913/ (Markdown: https://insights.sbomify.com/CVE-2021-39913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39913
- OSV: https://osv.dev/vulnerability/CVE-2021-39913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39913/
Summaries are generated and may contain mistakes; the official description above is the record.
