CVE-2021-39916 Missing authorization in GitLab
Authenticated users can retrieve configuration details of any External Status Check due to missing access control checks in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-39916?
CVE-2021-39916 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Lack of an access control check in the External Status Check feature allowed any authenticated user to retrieve the configuration of any External Status Check in GitLab EE starting from 14.1 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2.
Weakness: CWE-639
Which versions are affected by CVE-2021-39916?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.1.0 | 14.3.6, 14.4.4, 14.5.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-39916?
Upgrade gitlab to a fixed version for your release line: 14.3.6, 14.4.4 or 14.5.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-39916 being exploited?
There is no known exploitation of CVE-2021-39916 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-39916, GHSA-cxxv-5c8r-2cfh, UBUNTU-CVE-2021-39916.