CVE-2021-39917 Denial of service in GitLab

Medium 4.3 Published Updated

An attacker can cause a denial of service in GitLab by exploiting catastrophic backtracking in regular expressions used for quick actions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39917?

CVE-2021-39917 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 13 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.9 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. A regular expression related to quick actions features was susceptible to catastrophic backtracking that could cause a DOS attack.

Weakness: CWE-697

Which versions are affected by CVE-2021-39917?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.9.014.3.6, 14.4.4, 14.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-39917?

Upgrade gitlab to a fixed version for your release line: 14.3.6, 14.4.4 or 14.5.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-39917 being exploited?

There is no known exploitation of CVE-2021-39917 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39917, GHSA-86j2-r9c9-2h84, UBUNTU-CVE-2021-39917.

Is CVE-2021-39917 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free