# CVE-2021-3992: Improper Access Control in kevinpapst/kimai2

> Attackers can bypass access controls to read or modify unauthorized data in the Kimai time tracking application.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9w8f-7wgr-2h7g

## What is CVE-2021-3992?

CVE-2021-3992 is a medium-severity missing authorization vulnerability in kevinpapst/kimai2, published on 1 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

kimai2 is vulnerable to Improper Access Control

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2021-3992?

2 open source packages ship an affected version, including kevinpapst/kimai2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kevinpapst/kimai2` | Packagist | All versions | 1.16.3 |
| `kevinpapst/kimai2` | Packagist | All versions | 1.16.3 |

Products: Kimai2 Project Kimai2.

## How do I fix CVE-2021-3992?

Upgrade kevinpapst/kimai2 to 1.16.3 or later.

## Is CVE-2021-3992 being exploited?

There is no known exploitation of CVE-2021-3992 in the wild and no public exploit code.

## Other vulnerabilities in kevinpapst/kimai2

- [CVE-2021-3983](https://insights.sbomify.com/CVE-2021-3983/): Cross-site Scripting (XSS) - Stored in kevinpapst/kimai2 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3992 and fix it if it is affected.

What it is: CVE-2021-3992 is a medium-severity missing authorization vulnerability in kevinpapst/kimai2, published on 1 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3992 in the wild and no public exploit code.

Affected packages and fixed versions:
- kevinpapst/kimai2 (Packagist): affected all versions; fixed in 1.16.3
- kevinpapst/kimai2 (Packagist): affected all versions; fixed in 1.16.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3992/ (Markdown: https://insights.sbomify.com/CVE-2021-3992/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3992
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3992
- OSV: https://osv.dev/vulnerability/CVE-2021-3992

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3992/
Summaries are generated and may contain mistakes; the official description above is the record.
