CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)

Exploited in the wild Medium 6.8 Published Updated

Unauthorized external users can perform Server Side Requests via the CI Lint API, potentially accessing internal resources.

Exploited in the wild
Since 3 Feb 2026
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39935?

CVE-2021-39935 is a medium-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 13 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.5 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. Unauthorized external users could perform Server Side Requests via the CI Lint API

Weakness: CWE-918

Which versions are affected by CVE-2021-39935?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.5.014.3.6, 14.4.4, 14.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-39935?

Upgrade gitlab to a fixed version for your release line: 14.3.6, 14.4.4 or 14.5.2. US federal agencies must fix it by 24 Feb 2026.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2021-39935 being exploited?

Yes. Attackers have exploited CVE-2021-39935 in the wild since at least 3 Feb 2026.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39935, GHSA-22hj-9cx7-p2hw, UBUNTU-CVE-2021-39935.

Is CVE-2021-39935 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free