CVE-2021-39936 Missing authorization in GitLab

Low 3.5 Published Updated

An attacker with a deploy token can access a project's disabled wiki, bypassing intended access controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-39936?

CVE-2021-39936 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Improper access control in GitLab CE/EE affecting all versions starting from 10.7 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2, allows an attacker in possession of a deploy token to access a project's disabled wiki.

Weakness: CWE-863

Which versions are affected by CVE-2021-39936?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.7.014.3.6, 14.4.4, 14.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-39936?

Upgrade gitlab to a fixed version for your release line: 14.3.6, 14.4.4 or 14.5.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2021-39936 being exploited?

There is no known exploitation of CVE-2021-39936 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39936, GHSA-p6pm-7qxv-f8f3, UBUNTU-CVE-2021-39936.

Is CVE-2021-39936 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free