CVE-2021-39937 Privilege escalation in GitLab
A collision in access memoization logic allows attackers to gain elevated privileges in GitLab groups and projects under rare circumstances.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-39937?
CVE-2021-39937 is a medium-severity vulnerability in Gitlab Gitlab, published on 13 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A collision in access memoization logic in all versions of GitLab CE/EE before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2, leads to potential elevated privileges in groups and projects under rare circumstances
Weakness: CWE-269
Which versions are affected by CVE-2021-39937?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 14.3.6, 14.4.4, 14.5.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2021-39937?
Upgrade gitlab to a fixed version for your release line: 14.3.6, 14.4.4 or 14.5.2.
Is CVE-2021-39937 being exploited?
There is no known exploitation of CVE-2021-39937 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2021-39937, GHSA-r45q-p6m3-6gmv, UBUNTU-CVE-2021-39937.