CVE-2021-39938 Denial of service in GitLab

Low 3.1 Published Updated

An attacker can cause a Denial of Service in GitLab by sending specially crafted deploy slash commands that trigger a vulnerable regular expression.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39938?

CVE-2021-39938 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 13 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerable regular expression pattern in GitLab CE/EE since version 8.15 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2, allows an attacker to cause uncontrolled resource consumption leading to Denial of Service via specially crafted deploy Slash commands

Weakness: CWE-400

Which versions are affected by CVE-2021-39938?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.15.014.3.6, 14.4.4, 14.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-39938?

Upgrade gitlab to a fixed version for your release line: 14.3.6, 14.4.4 or 14.5.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-39938 being exploited?

There is no known exploitation of CVE-2021-39938 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39938, GHSA-g8j3-2rcp-jrhm, UBUNTU-CVE-2021-39938.

Is CVE-2021-39938 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free