CVE-2021-39943 Missing authorization in GitLab

Medium 4.3 Published Updated

An authorization logic error in GitLab EE allows users to improperly update external status check statuses via the API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39943?

CVE-2021-39943 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authorization logic error in the External Status Check API in GitLab EE affecting all versions starting from 14.1 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2, allowed a user to update the status of the check via an API call

Weakness: CWE-863

Which versions are affected by CVE-2021-39943?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.1.014.3.6, 14.4.4, 14.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2021-39943?

Upgrade gitlab to a fixed version for your release line: 14.3.6, 14.4.4 or 14.5.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2021-39943 being exploited?

There is no known exploitation of CVE-2021-39943 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2021-39943, GHSA-2hjx-qmr7-gg4r.

Is CVE-2021-39943 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free