# CVE-2021-40087: Information disclosure in n/a

> Cleartext enrollment secrets are logged in audit logs when protocol aliases change, exposing sensitive data to administrators.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-ejbca-2021-40087, GHSA-v766-f6mm-cqpp

## What is CVE-2021-40087?

CVE-2021-40087 is a low-severity vulnerability in n/a, published on 25 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue was discovered in PrimeKey EJBCA before 7.6.0. When audit logging changes to the alias configurations of various protocols that use an enrollment secret, any modifications to the secret were logged in cleartext in the audit log (that can only be viewed by an administrator). This affects use of any of the following protocols: SCEP, CMP, or EST.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2021-40087?

1 open source package ship an affected version, including ejbca. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ejbca` | Bitnami | All versions | 7.6.0 |

Products: Primekey Ejbca.

## How do I fix CVE-2021-40087?

Upgrade ejbca to 7.6.0 or later.

## Is CVE-2021-40087 being exploited?

There is no known exploitation of CVE-2021-40087 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-34831](https://insights.sbomify.com/CVE-2022-34831/): Business logic in n/a (critical 9.8)
- [CVE-2020-11630](https://insights.sbomify.com/CVE-2020-11630/): Deserialization in n/a (critical 9.8)
- [CVE-2020-11627](https://insights.sbomify.com/CVE-2020-11627/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2020-25276](https://insights.sbomify.com/CVE-2020-25276/): Security feature bypass in n/a (high 7.3)
- [CVE-2020-11629](https://insights.sbomify.com/CVE-2020-11629/): File upload in n/a (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-40087 and fix it if it is affected.

What it is: CVE-2021-40087 is a low-severity vulnerability in n/a, published on 25 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-40087 in the wild and no public exploit code.

Affected packages and fixed versions:
- ejbca (Bitnami): affected all versions; fixed in 7.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-40087/ (Markdown: https://insights.sbomify.com/CVE-2021-40087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-40087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-40087
- OSV: https://osv.dev/vulnerability/CVE-2021-40087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-40087/
Summaries are generated and may contain mistakes; the official description above is the record.
