# CVE-2021-40089: Security feature bypass in n/a

> Attackers can execute local scripts via existing publishers even when external script access is disabled, bypassing security controls in EJBCA.

- **Severity:** Low 2.3 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-ejbca-2021-40089, GHSA-jfp8-v3xr-q53j

## What is CVE-2021-40089?

CVE-2021-40089 is a low-severity vulnerability in n/a, published on 25 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in PrimeKey EJBCA before 7.6.0. The General Purpose Custom Publisher, which is normally run to invoke a local script upon a publishing operation, was still able to run if the System Configuration setting Enable External Script Access was disabled. With this setting disabled it's not possible to create new such publishers, but existing publishers would continue to run.

## Which versions are affected by CVE-2021-40089?

1 open source package ship an affected version, including ejbca. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ejbca` | Bitnami | All versions | 7.6.0 |

Products: Primekey Ejbca.

## How do I fix CVE-2021-40089?

Upgrade ejbca to 7.6.0 or later.

## Is CVE-2021-40089 being exploited?

There is no known exploitation of CVE-2021-40089 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-34831](https://insights.sbomify.com/CVE-2022-34831/): Business logic in n/a (critical 9.8)
- [CVE-2020-11630](https://insights.sbomify.com/CVE-2020-11630/): Deserialization in n/a (critical 9.8)
- [CVE-2020-11627](https://insights.sbomify.com/CVE-2020-11627/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2020-25276](https://insights.sbomify.com/CVE-2020-25276/): Security feature bypass in n/a (high 7.3)
- [CVE-2020-11629](https://insights.sbomify.com/CVE-2020-11629/): File upload in n/a (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-40089 and fix it if it is affected.

What it is: CVE-2021-40089 is a low-severity vulnerability in n/a, published on 25 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-40089 in the wild and no public exploit code.

Affected packages and fixed versions:
- ejbca (Bitnami): affected all versions; fixed in 7.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-40089/ (Markdown: https://insights.sbomify.com/CVE-2021-40089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-40089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-40089
- OSV: https://osv.dev/vulnerability/CVE-2021-40089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-40089/
Summaries are generated and may contain mistakes; the official description above is the record.
