CVE-2021-40110 Apache James IMAP vulnerable to a ReDoS

High 7.5 Published Updated

An attacker can cause a Denial of Service in Apache James by sending crafted IMAP LIST commands that trigger expensive regular expression backtracking.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-40110?

CVE-2021-40110 is a high-severity denial of service vulnerability in Apache James, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.

Which versions are affected by CVE-2021-40110?

2 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.

PackageAffectedFixed in
org.apache.james:james-server MavenFrom 3.1.03.6.1
org.apache.james:james-server MavenFrom 3.1.03.6.1

Products include Apache James.

How do I fix CVE-2021-40110?

Upgrade org.apache.james:james-server to 3.6.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-40110 being exploited?

There is no known exploitation of CVE-2021-40110 in the wild and no public exploit code.

Sources

Also known as GHSA-r58x-wjg8-63m9.

Is CVE-2021-40110 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free