{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-40110 in the wild and no public exploit code.","fix":"Upgrade org.apache.james:james-server to 3.6.1 or later.","what":"CVE-2021-40110 is a high-severity denial of service vulnerability in Apache James, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-40110 and fix it if it is affected.\n\nWhat it is: CVE-2021-40110 is a high-severity denial of service vulnerability in Apache James, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-40110 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.james:james-server (Maven): affected from 3.1.0; fixed in 3.6.1\n- org.apache.james:james-server (Maven): affected from 3.1.0; fixed in 3.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-40110/ (Markdown: https://insights.sbomify.com/CVE-2021-40110/index.md)","id":"CVE-2021-40110","markdown":"https://insights.sbomify.com/CVE-2021-40110/index.md","name":"CVE-2021-40110","record":{"aliases":["GHSA-r58x-wjg8-63m9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache James IMAP server","requires_auth":"none","summary":"An attacker can cause a Denial of Service in Apache James by sending crafted IMAP LIST commands that trigger expensive regular expression backtracking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"james","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache James IMAP vulnerable to a ReDoS","id":"CVE-2021-40110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Apache James IMAP parsing Denial Of Service","id":"CVE-2021-40111"},"packages":[{"ecosystem":"Maven","fixed":["3.6.1"],"introduced":["3.1.0"],"last_affected":[],"package":"org.apache.james:james-server","purl":null,"source":"GHSA-r58x-wjg8-63m9"},{"ecosystem":"Maven","fixed":["3.6.1"],"introduced":["3.1.0"],"last_affected":[],"package":"org.apache.james:james-server","purl":"pkg:maven/org.apache.james/james-server","source":"GHSA-r58x-wjg8-63m9"}],"prev":{"headline":"Server-side request forgery in n/a","id":"CVE-2021-40109"},"products":["Apache James"],"published":"2022-01-04","related":[{"cvss_score":9.8,"headline":"Apache James server: Privilege escalation via JMX pre-authentication deserialisation","id":"CVE-2023-51518","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":9.8,"headline":"Vulnerability that affects org.apache.pdfbox:pdfbox","id":"CVE-2019-0228","kev_date_added":null,"published":"2019-04-17"},{"cvss_score":9.1,"headline":"Sieve file storage vulnerable to path traversal attacks","id":"CVE-2021-40525","kev_date_added":null,"published":"2022-01-04"},{"cvss_score":7.8,"headline":"Apache James server: Privilege escalation through unauthenticated JMX","id":"CVE-2023-26269","kev_date_added":null,"published":"2023-04-03"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2006-2806","kev_date_added":null,"published":"2006-06-05"},{"cvss_score":7.5,"headline":"STARTTLS command injection in Apache JAMES","id":"CVE-2022-28220","kev_date_added":null,"published":"2022-09-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"An attacker can cause a Denial of Service in Apache James by sending crafted IMAP LIST commands that trigger expensive regular expression backtracking.","url":"https://insights.sbomify.com/CVE-2021-40110/"}