{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.any23:apache-any23. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-40146 in the wild and no public exploit code.","fix":"Upgrade org.apache.any23:apache-any23 to 2.5 or later.","what":"CVE-2021-40146 is a critical unsafe deserialization vulnerability in Apache Any23, published on 11 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-40146 and fix it if it is affected.\n\nWhat it is: CVE-2021-40146 is a critical unsafe deserialization vulnerability in Apache Any23, published on 11 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-40146 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.any23:apache-any23 (Maven): affected all versions; fixed in 2.5\n- org.apache.any23:apache-any23 (Maven): affected all versions; fixed in 2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-40146/ (Markdown: https://insights.sbomify.com/CVE-2021-40146/index.md)","id":"CVE-2021-40146","markdown":"https://insights.sbomify.com/CVE-2021-40146/index.md","name":"CVE-2021-40146","record":{"aliases":["GHSA-99px-7724-484v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Any23 library","requires_auth":"none","summary":"A remote code execution vulnerability in Apache Any23 allows attackers to execute arbitrary code via malicious YAML input.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"any23","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"A Remote Code Execution (RCE) vulnerability was discovered in the Any23 YAMLExtractor.java file and is known to affect Any23 versions \u003c 2.5. RCE vulnerabilities allow a malicious actor to execute any code of their choice on a remote machine over LAN, WAN, or internet. RCE belongs to the broader class of arbitrary code execution (ACE) vulnerabilities.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"A Remote Code Execution (RCE) vulnerability exists in Apache Any23 YAMLExtractor.java","id":"CVE-2021-40146","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Other in n/a","id":"CVE-2021-40147"},"packages":[{"ecosystem":"Maven","fixed":["2.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.any23:apache-any23","purl":null,"source":"GHSA-99px-7724-484v"},{"ecosystem":"Maven","fixed":["2.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.any23:apache-any23","purl":"pkg:maven/org.apache.any23/apache-any23","source":"GHSA-99px-7724-484v"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2021-40145"},"products":["Apache Any23"],"published":"2021-09-11","related":[{"cvss_score":9.1,"headline":"An XML external entity (XXE) injection vulnerability exists in the Apache Any23 RDFa XSLTStylesheet extractor","id":"CVE-2022-25312","kev_date_added":null,"published":"2022-03-04"},{"cvss_score":9.1,"headline":"An XML external entity (XXE) injection vulnerability exists in Apache Any23 StreamUtils.java","id":"CVE-2021-38555","kev_date_added":null,"published":"2021-09-11"},{"cvss_score":6.5,"headline":"Apache Any23: Possible excessive allocation of resources reading input.","id":"CVE-2023-34150","kev_date_added":null,"published":"2023-07-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"A remote code execution vulnerability in Apache Any23 allows attackers to execute arbitrary code via malicious YAML input.","url":"https://insights.sbomify.com/CVE-2021-40146/"}