# CVE-2021-4024: Exposure of Sensitive Information to an Unauthorized Actor and Origin Validation Error in podman

> An attacker can use the gvproxy API to forward host ports to VM services, exposing private services or disrupting host operations.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-4024, GHSA-3cf2-x423-x582, GO-2022-0281, UBUNTU-CVE-2021-4024

## What is CVE-2021-4024?

CVE-2021-4024 is a medium-severity server-side request forgery vulnerability in Fedoraproject Fedora, published on 23 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in podman. The `podman machine` function (used to create and manage Podman virtual machine containing a Podman process) spawns a `gvproxy` process on the host system. The `gvproxy` API is accessible on port 7777 on all IP addresses on the host. If that port is open on the host's firewall, an attacker can potentially use the `gvproxy` API to forward ports on the host to ports in the VM, making private services on the VM accessible to the network. This issue could be also used to interrupt the host's services by forwarding all ports to the VM.

Weakness: CWE-346 (Origin Validation Error), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-4024?

5 open source packages ship an affected version, including github.com/containers/podman/v3, github.com/containers/podman and github.com/containers/podman/v2. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman/v3` | Go | All versions | 3.4.3 |
| `github.com/containers/podman/v3` | Go | All versions | 3.4.3 |
| `github.com/containers/podman/v3` | Go | All versions | 3.4.3 |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman/v2` | Go | All versions | None |

Products: Fedoraproject Fedora, Podman Project Podman, Redhat Enterprise Linux.

## How do I fix CVE-2021-4024?

Upgrade github.com/containers/podman/v3 to 3.4.3 or later.

## Is CVE-2021-4024 being exploited?

There is no known exploitation of CVE-2021-4024 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4024 and fix it if it is affected.

What it is: CVE-2021-4024 is a medium-severity server-side request forgery vulnerability in Fedoraproject Fedora, published on 23 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4024 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman/v3 (Go): affected all versions; fixed in 3.4.3
- github.com/containers/podman/v3 (Go): affected all versions; fixed in 3.4.3
- github.com/containers/podman/v3 (Go): affected all versions; fixed in 3.4.3
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4024/ (Markdown: https://insights.sbomify.com/CVE-2021-4024/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4024
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4024
- OSV: https://osv.dev/vulnerability/CVE-2021-4024

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4024/
Summaries are generated and may contain mistakes; the official description above is the record.
