{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-40325 in the wild and no public exploit code.","fix":"Upgrade cobbler to 3.3.0 or later.","what":"CVE-2021-40325 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-40325 and fix it if it is affected.\n\nWhat it is: CVE-2021-40325 is a high-severity missing authorization vulnerability in n/a, published on 4 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-40325 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 3.3.0\n- cobbler (PyPI): affected all versions; fixed in 3.3.0\n- cobbler (PyPI): affected all versions; fixed in 3.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-40325/ (Markdown: https://insights.sbomify.com/CVE-2021-40325/index.md)","id":"CVE-2021-40325","markdown":"https://insights.sbomify.com/CVE-2021-40325/index.md","name":"CVE-2021-40325","record":{"aliases":["GHSA-cr3f-r24j-3chw","PYSEC-2021-375","UBUNTU-CVE-2021-40325"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"none","summary":"Attackers can bypass authorization to modify Cobbler settings, potentially compromising the provisioning infrastructure.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cobbler","vendor":"cobbler_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[],"description":"Cobbler before 3.3.0 allows authorization bypass for modification of settings.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler before 3.3.0 allows authorization bypass for modification of settings.","id":"CVE-2021-40325","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Other in n/a","id":"CVE-2021-40326"},"packages":[{"ecosystem":"PyPI","fixed":["3.3.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-cr3f-r24j-3chw"},{"ecosystem":"PyPI","fixed":["3.3.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-cr3f-r24j-3chw"},{"ecosystem":"PyPI","fixed":["3.3.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2021-375"}],"prev":{"headline":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.","id":"CVE-2021-40324"},"products":["n/a"],"published":"2021-10-04","related":[{"cvss_score":9.8,"headline":"Cobbler before 3.3.0 allows log poisoning","id":"CVE-2021-40323","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":9.8,"headline":"Cobbler has Exposed Dangerous Method or Function","id":"CVE-2018-10931","kev_date_added":null,"published":"2018-08-09"},{"cvss_score":9.8,"headline":"Cobbler vulnerable to arbitrary code execution","id":"CVE-2017-1000469","kev_date_added":null,"published":"2018-01-03"},{"cvss_score":8.2,"headline":"Improper Authorization in cobbler/cobbler","id":"CVE-2022-0860","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":7.8,"headline":"Command Injection in Cobbler","id":"CVE-2021-45082","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.","id":"CVE-2021-40324","kev_date_added":null,"published":"2021-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can bypass authorization to modify Cobbler settings, potentially compromising the provisioning infrastructure.","url":"https://insights.sbomify.com/CVE-2021-40325/"}