CVE-2021-40331 Permissions problem in the Apache Ranger Hive Plugin

High 8.1 Published Updated

Users with SELECT privileges can improperly alter table ownership in Hive when the Apache Ranger Hive Plugin is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-40331?

CVE-2021-40331 is a high-severity missing authorization vulnerability in Apache Ranger Hive Plugin, published on 5 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.

Weakness: CWE-732

Which versions are affected by CVE-2021-40331?

2 open source packages ship an affected version, including org.apache.ranger:ranger-hive-plugin. It affects 1 product.

PackageAffectedFixed in
org.apache.ranger:ranger-hive-plugin MavenFrom 2.0.02.4.0
org.apache.ranger:ranger-hive-plugin MavenFrom 2.0.02.4.0

Products include Apache Ranger.

How do I fix CVE-2021-40331?

Upgrade org.apache.ranger:ranger-hive-plugin to 2.4.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2021-40331 being exploited?

There is no known exploitation of CVE-2021-40331 in the wild and no public exploit code.

Sources

Also known as GHSA-vjr2-wpfh-5r9p.

Is CVE-2021-40331 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free