CVE-2021-40346 Integer overflow in n/a
An integer overflow in HAProxy allows HTTP request smuggling, enabling attackers to bypass configured ACLs and security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-40346?
CVE-2021-40346 is a high-severity vulnerability in Debian Debian Linux, published on 8 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An integer overflow exists in HAProxy 2.0 through 2.5 in htx_add_header that can be exploited to perform an HTTP request smuggling attack, allowing an attacker to bypass all configured http-request HAProxy ACLs and possibly other ACLs.
Weakness: CWE-190
Which versions are affected by CVE-2021-40346?
1 open source package ship an affected version, including haproxy. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
haproxy Bitnami | From 2.0.0 | 2.0.25, 2.2.17, 2.3.14, 2.4.4 |
Linux distribution packages (6)
haproxy SUSE:Linux Enterprise High Availability Extension 15 | All versions | 2.0.14-3.31.1 |
haproxy SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 2.0.14-8.23.1 |
haproxy SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 2.0.14-11.11.1 |
haproxy SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 2.0.14-11.11.1 |
haproxy openSUSE:Leap 15.2 | All versions | 2.0.14-lp152.2.6.1 |
haproxy openSUSE:Leap 15.3 | All versions | 2.0.14-11.11.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Haproxy Haproxy.
How do I fix CVE-2021-40346?
Upgrade haproxy to a fixed version for your release line: 2.0.25, 2.2.17, 2.3.14 or 2.4.4.
Is CVE-2021-40346 being exploited?
There is no known exploitation of CVE-2021-40346 in the wild and no public exploit code.
Public exploit code: 7 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-haproxy-2021-40346, DEBIAN-CVE-2021-40346, DSA-4968-1, GHSA-jwmg-q4wv-f75h, OESA-2021-1367, SUSE-SU-2021:2975-1 and 6 more.