# CVE-2021-40346: Integer overflow in n/a

> An integer overflow in HAProxy allows HTTP request smuggling, enabling attackers to bypass configured ACLs and security controls.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-haproxy-2021-40346, DEBIAN-CVE-2021-40346, DSA-4968-1, GHSA-jwmg-q4wv-f75h, OESA-2021-1367, SUSE-SU-2021:2975-1, SUSE-SU-2021:3257-1, SUSE-SU-2021:3258-1, UBUNTU-CVE-2021-40346, USN-5063-1, openSUSE-SU-2021:1329-1, openSUSE-SU-2021:2975-1

## What is CVE-2021-40346?

CVE-2021-40346 is a high-severity vulnerability in Debian Debian Linux, published on 8 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An integer overflow exists in HAProxy 2.0 through 2.5 in htx_add_header that can be exploited to perform an HTTP request smuggling attack, allowing an attacker to bypass all configured http-request HAProxy ACLs and possibly other ACLs.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2021-40346?

1 open source package ship an affected version, including haproxy. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | From 2.0.0 | 2.0.25, 2.2.17, 2.3.14, 2.4.4 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 2.0.14-3.31.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 2.0.14-8.23.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 2.0.14-11.11.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 2.0.14-11.11.1 |
| `haproxy` | openSUSE:Leap 15.2 | All versions | 2.0.14-lp152.2.6.1 |
| `haproxy` | openSUSE:Leap 15.3 | All versions | 2.0.14-11.11.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Haproxy Haproxy.

## How do I fix CVE-2021-40346?

Upgrade haproxy to a fixed version for your release line: 2.0.25, 2.2.17, 2.3.14 or 2.4.4.

## Is CVE-2021-40346 being exploited?

There is no known exploitation of CVE-2021-40346 in the wild and no public exploit code.

Public exploit code:

- CVE-2021-40346 PoC (HAProxy HTTP Smuggling) (github_poc): https://github.com/knqyf263/CVE-2021-40346
- CVE-2021-40346 integer overflow enables http smuggling (github_poc): https://github.com/donky16/CVE-2021-40346-POC
- https://github.com/alikarimi999/CVE-2021-40346 (github_poc): https://github.com/alikarimi999/CVE-2021-40346
- HAProxy CVE-2021-40346 (github_poc): https://github.com/Vulnmachines/HAProxy_CVE-2021-40346
- CVE-2021-40346 - HaProxy HTTP request smuggling through integer overflow (github_poc): https://github.com/alexOarga/CVE-2021-40346
- HTTP Request Smuggling (github_poc): https://github.com/BoianEduard/CVE-2021-40346

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-40346 and fix it if it is affected.

What it is: CVE-2021-40346 is a high-severity vulnerability in Debian Debian Linux, published on 8 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-40346 in the wild and no public exploit code.

Affected packages and fixed versions:
- haproxy (Bitnami): affected from 2.0.0; fixed in 2.0.25, 2.2.17, 2.3.14, 2.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-40346/ (Markdown: https://insights.sbomify.com/CVE-2021-40346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-40346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-40346
- OSV: https://osv.dev/vulnerability/CVE-2021-40346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-40346/
Summaries are generated and may contain mistakes; the official description above is the record.
