# CVE-2021-40347: GNU Mailman Postorius Access Control Issues


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-40347, DSA-4970-1, GHSA-v83x-78q3-gr2j, PYSEC-2021-319, UBUNTU-CVE-2021-40347, USN-5157-1

## What is CVE-2021-40347?

CVE-2021-40347 is a medium-severity vulnerability in n/a, published on 10 Sep 2021. 

### Official description

An issue was discovered in views/list.py in GNU Mailman Postorius before 1.3.5. An attacker (logged into any account) can send a crafted POST request to unsubscribe any user from a mailing list, also revealing whether that address was subscribed in the first place.

## Which versions are affected by CVE-2021-40347?

3 open source packages ship an affected version, including postorius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postorius` | PyPI | All versions | 1.3.5 |
| `postorius` | PyPI | All versions | 1.3.5 |
| `postorius` | PyPI | All versions | 1.3.5 |

Products: Postorius Project Postorius.

## How do I fix CVE-2021-40347?

Upgrade postorius to 1.3.5 or later.

## Is CVE-2021-40347 being exploited?

There is no known exploitation of CVE-2021-40347 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-44742](https://insights.sbomify.com/CVE-2026-44742/): Postorius is vulnerable to XSS (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-40347 and fix it if it is affected.

What it is: CVE-2021-40347 is a medium-severity vulnerability in n/a, published on 10 Sep 2021. 
Exploitation: There is no known exploitation of CVE-2021-40347 in the wild and no public exploit code.

Affected packages and fixed versions:
- postorius (PyPI): affected all versions; fixed in 1.3.5
- postorius (PyPI): affected all versions; fixed in 1.3.5
- postorius (PyPI): affected all versions; fixed in 1.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-40347/ (Markdown: https://insights.sbomify.com/CVE-2021-40347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-40347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-40347
- OSV: https://osv.dev/vulnerability/CVE-2021-40347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-40347/
Summaries are generated and may contain mistakes; the official description above is the record.
