# CVE-2021-4041: ansible-runner vulnerable to shell command injection

> Improper escaping in ansible-runner allows attackers to execute arbitrary shell commands on the host system via crafted parameters.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-4041, GHSA-6j58-grhv-2769, PYSEC-2022-253, RHSA-2022:0108, UBUNTU-CVE-2021-4041

## What is CVE-2021-4041?

CVE-2021-4041 is a high-severity command injection vulnerability in ansible-runner, published on 24 Aug 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in ansible-runner. An improper escaping of the shell command, while calling the ansible_runner.interface.run_command, can lead to parameters getting executed as host's shell command. A developer could unintentionally write code that gets executed in the host rather than the virtual environment.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-4041?

3 open source packages ship an affected version, including ansible-runner. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible-runner` | PyPI | All versions | 2.1.0 |
| `ansible-runner` | PyPI | All versions | 2.1.0 |
| `ansible-runner` | PyPI | All versions | 2.1.0 |
| `ansible-runner` | Red Hat:ansible_automation_platform:2.0::el8 | All versions | 0:2.0.3-2.el8ap |
| `python38-ansible-runner` | Red Hat:ansible_automation_platform:2.0::el8 | All versions | 0:2.0.3-2.el8ap |

Products: Redhat Ansible Runner.

## How do I fix CVE-2021-4041?

Upgrade ansible-runner to 2.1.0 or later.

## Is CVE-2021-4041 being exploited?

There is no known exploitation of CVE-2021-4041 in the wild and no public exploit code.

## Other vulnerabilities in ansible-runner

- [CVE-2021-3701](https://insights.sbomify.com/CVE-2021-3701/): ansible-runner has default temporary files written to world R/W locations (medium 6.6)
- [CVE-2021-3702](https://insights.sbomify.com/CVE-2021-3702/): ansible-runner vulnerable to Race Condition (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4041 and fix it if it is affected.

What it is: CVE-2021-4041 is a high-severity command injection vulnerability in ansible-runner, published on 24 Aug 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-4041 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible-runner (PyPI): affected all versions; fixed in 2.1.0
- ansible-runner (PyPI): affected all versions; fixed in 2.1.0
- ansible-runner (PyPI): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4041/ (Markdown: https://insights.sbomify.com/CVE-2021-4041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4041
- OSV: https://osv.dev/vulnerability/CVE-2021-4041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4041/
Summaries are generated and may contain mistakes; the official description above is the record.
