CVE-2021-4044 Invalid handling of X509_verify_cert() internal errors in libssl
An attacker can cause application crashes or infinite loops in OpenSSL clients by triggering mishandled internal certificate verification errors.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-4044?
CVE-2021-4044 is a high-severity denial of service vulnerability in Netapp Cloud Backup, published on 14 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Internally libssl in OpenSSL calls X509_verify_cert() on the client side to verify a certificate supplied by a server. That function may return a negative return value to indicate an internal error (for example out of memory). Such a negative return value is mishandled by OpenSSL and will cause an IO function (such as SSL_connect() or SSL_do_handshake()) to not indicate success and a subsequent call to SSL_get_error() to return the value SSL_ERROR_WANT_RETRY_VERIFY. This return value is only supposed to be returned by OpenSSL if the application has previously called SSL_CTX_set_cert_verify_callback(). Since most applications do not do this the SSL_ERROR_WANT_RETRY_VERIFY return value from SSL_get_error() will be totally unexpected and applications may not behave correctly as a result. The exact behaviour will depend on the application but it could result in crashes, infinite loops or other similar incorrect responses. This issue is made more serious in combination with a separate bug in OpenSSL 3.0 that will cause X509_verify_cert() to indicate an internal error when processing a certificate chain. This will occur where a certificate does not include the Subject Alternative Name extension but where a Certificate Authority has enforced name constraints. This issue can occur even with valid chains. By combining the two issues an attacker could induce incorrect, application dependent behaviour. Fixed in OpenSSL 3.0.1 (Affected 3.0.0).
Weakness: CWE-835
Which versions are affected by CVE-2021-4044?
5 open source packages ship an affected version, including openssl-src, node and node-min. It affects 16 products.
| Package | Affected | Fixed in |
|---|---|---|
openssl-src crates.io | From 300.0.0 | 300.0.4 |
openssl-src crates.io | From 300.0.0 | 300.0.4 |
openssl-src crates.io | From 300.0.0 | 300.0.4 |
node Bitnami | From 17.0.0 | 17.3.0 |
node-min Bitnami | From 17.0.0 | 17.3.0 |
Products include Netapp 500f Firmware, Netapp A250 Firmware, Netapp Cloud Backup, Netapp E-Series Performance Analyzer, Netapp H300e Firmware, Netapp H300s Firmware and 10 more.
How do I fix CVE-2021-4044?
Upgrade openssl-src to 300.0.4 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-4044 being exploited?
There is no known exploitation of CVE-2021-4044 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Netapp Cloud Backup
Sources
Also known as ALPINE-CVE-2021-4044, BIT-node-2021-4044, BIT-node-min-2021-4044, CLEANSTART-2026-VH14803, GHSA-mmjf-f5jw-w72q, RUSTSEC-2021-0129 and 1 more.