# CVE-2021-40525: Sieve file storage vulnerable to path traversal attacks


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c38m-7h53-g9v4

## What is CVE-2021-40525?

CVE-2021-40525 is a critical vulnerability in Apache James, published on 4 Jan 2022. 

### Official description

Apache James ManagedSieve implementation alongside with the file storage for sieve scripts is vulnerable to path traversal, allowing reading and writing any file. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade. Distributed and Cassandra based products are also not impacted.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-40525?

2 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james:james-server` | Maven | All versions | 3.6.1 |
| `org.apache.james:james-server` | Maven | All versions | 3.6.1 |

Products: Apache James.

## How do I fix CVE-2021-40525?

Upgrade org.apache.james:james-server to 3.6.1 or later.

## Is CVE-2021-40525 being exploited?

There is no known exploitation of CVE-2021-40525 in the wild and no public exploit code.

## Other vulnerabilities in Apache James

- [CVE-2023-51518](https://insights.sbomify.com/CVE-2023-51518/): Apache James server: Privilege escalation via JMX pre-authentication deserialisation (critical 9.8)
- [CVE-2019-0228](https://insights.sbomify.com/CVE-2019-0228/): Vulnerability that affects org.apache.pdfbox:pdfbox (critical 9.8)
- [CVE-2023-26269](https://insights.sbomify.com/CVE-2023-26269/): Apache James server: Privilege escalation through unauthenticated JMX (high 7.8)
- [CVE-2006-2806](https://insights.sbomify.com/CVE-2006-2806/): Denial of service in n/a (high 7.8)
- [CVE-2022-28220](https://insights.sbomify.com/CVE-2022-28220/): STARTTLS command injection in Apache JAMES (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-40525 and fix it if it is affected.

What it is: CVE-2021-40525 is a critical vulnerability in Apache James, published on 4 Jan 2022. 
Exploitation: There is no known exploitation of CVE-2021-40525 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.6.1
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-40525/ (Markdown: https://insights.sbomify.com/CVE-2021-40525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-40525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-40525
- OSV: https://osv.dev/vulnerability/CVE-2021-40525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-40525/
Summaries are generated and may contain mistakes; the official description above is the record.
