CVE-2021-40691 Moodle Improper Authentication
Attackers can hijack sessions in Moodle's Shibboleth authentication plugin, potentially taking over user accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-40691?
CVE-2021-40691 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 21 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A session hijack risk was identified in the Shibboleth authentication plugin.
Which versions are affected by CVE-2021-40691?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.7 |
moodle/moodle Packagist | From 3.10 | 3.10.7 |
moodle/moodle Packagist | From 3.11 | 3.11.3 |
moodle/moodle Packagist | From 3.11 | 3.11.3 |
moodle/moodle Packagist | From 3.9 | 3.9.10 |
moodle/moodle Packagist | From 3.9 | 3.9.10 |
1 more packages
moodle Bitnami | All versions | 3.9.10, 3.10.7, 3.11.3 |
Products include Moodle Moodle.
How do I fix CVE-2021-40691?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.7, 3.11.3 or 3.9.10.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2021-40691 being exploited?
There is no known exploitation of CVE-2021-40691 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-40691, GHSA-92vh-mr2w-j2cr, UBUNTU-CVE-2021-40691.