CVE-2021-40692 Moodle Incorrect Authorization
Teachers can download user data from courses they do not manage due to insufficient capability checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-40692?
CVE-2021-40692 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 21 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Insufficient capability checks made it possible for teachers to download users outside of their courses.
Weakness: CWE-863
Which versions are affected by CVE-2021-40692?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.7 |
moodle/moodle Packagist | From 3.10 | 3.10.7 |
moodle/moodle Packagist | From 3.11 | 3.11.3 |
moodle/moodle Packagist | From 3.11 | 3.11.3 |
moodle/moodle Packagist | From 3.9 | 3.9.10 |
moodle/moodle Packagist | From 3.9 | 3.9.10 |
1 more packages
moodle Bitnami | From 3.9.0 | 3.9.10, 3.10.7, 3.11.3 |
Products include Moodle Moodle.
How do I fix CVE-2021-40692?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.7, 3.11.3 or 3.9.10.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-40692 being exploited?
There is no known exploitation of CVE-2021-40692 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-40692, GHSA-wr6q-xv23-rfq9, UBUNTU-CVE-2021-40692.