CVE-2021-40694 Moodle Improper Encoding or Escaping of Output
Site administrators can read arbitrary files accessible to the web server via insufficient LaTeX preamble escaping.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-40694?
CVE-2021-40694 is a medium-severity path traversal vulnerability in Moodle Moodle, published on 21 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Insufficient escaping of the LaTeX preamble made it possible for site administrators to read files available to the HTTP server system account.
Weakness: CWE-116
Which versions are affected by CVE-2021-40694?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.7 |
moodle/moodle Packagist | From 3.10 | 3.10.7 |
moodle/moodle Packagist | From 3.11 | 3.11.3 |
moodle/moodle Packagist | From 3.11 | 3.11.3 |
moodle/moodle Packagist | From 3.9 | 3.9.10 |
moodle/moodle Packagist | From 3.9 | 3.9.10 |
1 more packages
moodle Bitnami | All versions | 3.9.10, 3.10.7, 3.11.3 |
Products include Moodle Moodle.
How do I fix CVE-2021-40694?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.7, 3.11.3 or 3.9.10.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2021-40694 being exploited?
There is no known exploitation of CVE-2021-40694 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-40694, GHSA-m37g-mwcg-7j7v, UBUNTU-CVE-2021-40694.