{"answers":{"affected":"7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-40695 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.10.7, 3.11.3 or 3.9.10.","what":"CVE-2021-40695 is a medium-severity vulnerability in Moodle Moodle, published on 21 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-40695 and fix it if it is affected.\n\nWhat it is: CVE-2021-40695 is a medium-severity vulnerability in Moodle Moodle, published on 21 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-40695 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.7\n- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.7\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.3\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.3\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.10\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.10\n- moodle (Bitnami): affected from 3.9.0; fixed in 3.9.10, 3.10.7, 3.11.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-40695/ (Markdown: https://insights.sbomify.com/CVE-2021-40695/index.md)","id":"CVE-2021-40695","markdown":"https://insights.sbomify.com/CVE-2021-40695/index.md","name":"CVE-2021-40695","record":{"aliases":["BIT-moodle-2021-40695","GHSA-gp4w-f57r-9rx3","UBUNTU-CVE-2021-40695"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Students can view unreleased quiz grades via a web service, exposing sensitive assessment data prematurely.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[],"description":"It was possible for a student to view their quiz grade before it had been released, using a quiz web service.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Exposure of Sensitive Information to an Unauthorized Actor","id":"CVE-2021-40695","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"information_disclosure","year":"2021"},"n_packages":7,"n_references":1,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2021-40696"},"packages":[{"ecosystem":"Bitnami","fixed":["3.9.10","3.10.7","3.11.3"],"introduced":["3.9.0","3.10.0","3.11.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2021-40695"},{"ecosystem":"Packagist","fixed":["3.10.7"],"introduced":["3.10"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gp4w-f57r-9rx3"},{"ecosystem":"Packagist","fixed":["3.10.7"],"introduced":["3.10"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gp4w-f57r-9rx3"},{"ecosystem":"Packagist","fixed":["3.11.3"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gp4w-f57r-9rx3"},{"ecosystem":"Packagist","fixed":["3.11.3"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gp4w-f57r-9rx3"},{"ecosystem":"Packagist","fixed":["3.9.10"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gp4w-f57r-9rx3"},{"ecosystem":"Packagist","fixed":["3.9.10"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gp4w-f57r-9rx3"}],"prev":{"headline":"Moodle Improper Encoding or Escaping of Output","id":"CVE-2021-40694"},"products":["moodle"],"published":"2022-01-21","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Students can view unreleased quiz grades via a web service, exposing sensitive assessment data prematurely.","url":"https://insights.sbomify.com/CVE-2021-40695/"}