# CVE-2021-4070: Off-by-one Error in v2fly/v2ray-core

> An off-by-one error in the v2ray-core library allows attackers to cause denial of service or potentially execute code.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-4070, GHSA-4cxw-hq44-r344, GO-2022-0550, UBUNTU-CVE-2021-4070

## What is CVE-2021-4070?

CVE-2021-4070 is a medium-severity vulnerability in v2fly/v2ray-core, published on 23 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Off-by-one Error in GitHub repository v2fly/v2ray-core prior to 4.44.0.

Weakness: CWE-193 (Off-by-one Error)

## Which versions are affected by CVE-2021-4070?

6 open source packages ship an affected version, including github.com/v2fly/v2ray-core and github.com/v2fly/v2ray-core/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/v2fly/v2ray-core` | Go | All versions | None |
| `github.com/v2fly/v2ray-core` | Go | All versions | None |
| `github.com/v2fly/v2ray-core` | Go | All versions | None |
| `github.com/v2fly/v2ray-core/v4` | Go | All versions | 4.44.0 |
| `github.com/v2fly/v2ray-core/v4` | Go | All versions | 4.44.0 |
| `github.com/v2fly/v2ray-core/v4` | Go | All versions | 4.44.0 |

Products: V2fly V2ray-Core.

## How do I fix CVE-2021-4070?

Upgrade to a fixed version.

## Is CVE-2021-4070 being exploited?

There is no known exploitation of CVE-2021-4070 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4070 and fix it if it is affected.

What it is: CVE-2021-4070 is a medium-severity vulnerability in v2fly/v2ray-core, published on 23 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4070 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/v2fly/v2ray-core (Go): affected all versions; no fix listed
- github.com/v2fly/v2ray-core (Go): affected all versions; no fix listed
- github.com/v2fly/v2ray-core (Go): affected all versions; no fix listed
- github.com/v2fly/v2ray-core/v4 (Go): affected all versions; fixed in 4.44.0
- github.com/v2fly/v2ray-core/v4 (Go): affected all versions; fixed in 4.44.0
- github.com/v2fly/v2ray-core/v4 (Go): affected all versions; fixed in 4.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4070/ (Markdown: https://insights.sbomify.com/CVE-2021-4070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4070
- OSV: https://osv.dev/vulnerability/CVE-2021-4070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4070/
Summaries are generated and may contain mistakes; the official description above is the record.
