# CVE-2021-40720: Ops CLI Deserialization of Untrusted Data leads to Abritrary Code Execution

> An attacker can execute arbitrary code on a victim's machine by tricking them into processing a maliciously crafted file with Adobe Ops CLI.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-x23q-4j9j-9cxw, PYSEC-2021-380

## What is CVE-2021-40720?

CVE-2021-40720 is a critical unsafe deserialization vulnerability in Adobe Ops-CLI, published on 15 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkout_repo function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-40720?

3 open source packages ship an affected version, including ops-cli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ops-cli` | PyPI | All versions | 2.0.5 |
| `ops-cli` | PyPI | All versions | 2.0.5 |
| `ops-cli` | PyPI | All versions | 2.0.5 |

Products: Adobe Ops-Cli.

## How do I fix CVE-2021-40720?

Upgrade ops-cli to 2.0.5 or later.

## Is CVE-2021-40720 being exploited?

There is no known exploitation of CVE-2021-40720 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-40720 and fix it if it is affected.

What it is: CVE-2021-40720 is a critical unsafe deserialization vulnerability in Adobe Ops-CLI, published on 15 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-40720 in the wild and no public exploit code.

Affected packages and fixed versions:
- ops-cli (PyPI): affected all versions; fixed in 2.0.5
- ops-cli (PyPI): affected all versions; fixed in 2.0.5
- ops-cli (PyPI): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-40720/ (Markdown: https://insights.sbomify.com/CVE-2021-40720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-40720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-40720
- OSV: https://osv.dev/vulnerability/CVE-2021-40720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-40720/
Summaries are generated and may contain mistakes; the official description above is the record.
