# CVE-2021-40797: OpenStack Neutron Denial of Service vulnerability

> An authenticated user can cause memory exhaustion and denial of service in OpenStack Neutron API workers by requesting nonexistent controllers.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-40797, GHSA-cpx3-696p-3cw9, PYSEC-2021-329, RHSA-2022:0990, RHSA-2022:0996, UBUNTU-CVE-2021-40797

## What is CVE-2021-40797?

CVE-2021-40797 is a medium-severity denial of service vulnerability in n/a, published on 8 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in the routes middleware in OpenStack Neutron before 16.4.1, 17.x before 17.2.1, and 18.x before 18.1.1. By making API requests involving nonexistent controllers, an authenticated user may cause the API worker to consume increasing amounts of memory, resulting in API performance degradation or denial of service.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2021-40797?

7 open source packages ship an affected version, including neutron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | All versions | 16.4.1, 17.2.1, 18.1.1 |
| `neutron` | PyPI | All versions | 16.4.1 |
| `neutron` | PyPI | All versions | 16.4.1 |
| `neutron` | PyPI | From 17.0.0 | 17.2.1 |
| `neutron` | PyPI | From 17.0.0 | 17.2.1 |
| `neutron` | PyPI | From 18.0.0 | 18.1.1 |
| `neutron` | PyPI | From 18.0.0 | 18.1.1 |
| `openstack-neutron` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron-common` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron-linuxbridge` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron-macvtap-agent` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron-metering-agent` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron-ml2` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron-openvswitch` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron-rpc-server` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron-sriov-nic-agent` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `python3-neutron` | Red Hat:openstack:16.1::el8 | All versions | 1:15.2.1-1.20220112133420.el8ost |
| `openstack-neutron` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `openstack-neutron-common` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `openstack-neutron-linuxbridge` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `openstack-neutron-macvtap-agent` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `openstack-neutron-metering-agent` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `openstack-neutron-ml2` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `openstack-neutron-openvswitch` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `openstack-neutron-rpc-server` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `openstack-neutron-sriov-nic-agent` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |
| `python3-neutron` | Red Hat:openstack:16.2::el8 | All versions | 1:15.3.5-2.20220113150031.el8ost |

Products: Openstack Neutron.

## How do I fix CVE-2021-40797?

Upgrade neutron to a fixed version for your release line: 16.4.1, 17.2.1 or 18.1.1.

## Is CVE-2021-40797 being exploited?

There is no known exploitation of CVE-2021-40797 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-38598](https://insights.sbomify.com/CVE-2021-38598/): OpenStack Neutron vulnerable to hardware address impersonation (critical 9.1)
- [CVE-2015-8914](https://insights.sbomify.com/CVE-2015-8914/): OpenStack Neutron allows remote attackers to bypass an intended ICMPv6-spoofing protection mechanism (critical 9.1)
- [CVE-2016-5362](https://insights.sbomify.com/CVE-2016-5362/): OpenStack Neutron allows remote attackers to bypass an intended DHCP-spoofing protection mechanism (high 8.2)
- [CVE-2016-5363](https://insights.sbomify.com/CVE-2016-5363/): OpenStack Neutron Intended MAC-spoofing protection mechanism bypass (high 8.2)
- [CVE-2014-3632](https://insights.sbomify.com/CVE-2014-3632/): Privilege escalation in n/a (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-40797 and fix it if it is affected.

What it is: CVE-2021-40797 is a medium-severity denial of service vulnerability in n/a, published on 8 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-40797 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected all versions; fixed in 16.4.1, 17.2.1, 18.1.1
- neutron (PyPI): affected all versions; fixed in 16.4.1
- neutron (PyPI): affected all versions; fixed in 16.4.1
- neutron (PyPI): affected from 17.0.0; fixed in 17.2.1
- neutron (PyPI): affected from 17.0.0; fixed in 17.2.1
- neutron (PyPI): affected from 18.0.0; fixed in 18.1.1
- neutron (PyPI): affected from 18.0.0; fixed in 18.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-40797/ (Markdown: https://insights.sbomify.com/CVE-2021-40797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-40797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-40797
- OSV: https://osv.dev/vulnerability/CVE-2021-40797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-40797/
Summaries are generated and may contain mistakes; the official description above is the record.
