{"answers":{"affected":"2 open source packages ship an affected version, including @theia/plugin-ext. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41038 in the wild and no public exploit code.","fix":"Upgrade @theia/plugin-ext to 1.18.0 or later.","what":"CVE-2021-41038 is a medium-severity cross-site scripting vulnerability in @theia/plugin-ext, published on 10 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-41038 and fix it if it is affected.\n\nWhat it is: CVE-2021-41038 is a medium-severity cross-site scripting vulnerability in @theia/plugin-ext, published on 10 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-41038 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @theia/plugin-ext (npm): affected all versions; fixed in 1.18.0\n- @theia/plugin-ext (npm): affected all versions; fixed in 1.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41038/ (Markdown: https://insights.sbomify.com/CVE-2021-41038/index.md)","id":"CVE-2021-41038","markdown":"https://insights.sbomify.com/CVE-2021-41038/index.md","name":"CVE-2021-41038","record":{"aliases":["GHSA-w6v7-w58j-pg5r"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Eclipse Theia plugin","requires_auth":"none","summary":"Attackers can hijack Webview contents in Eclipse Theia via postMessage, potentially executing malicious code or bypassing security controls.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"eclipse","cpe":[{"product":"theia","vendor":"eclipse"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-940","name":"Improper Verification of Source of a Communication Channel"}],"description":"In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Verification of Communication Channel in @theia/plugin-ext","id":"CVE-2021-41038","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in Eclipse Mosquitto","id":"CVE-2021-41039"},"packages":[{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"@theia/plugin-ext","purl":null,"source":"GHSA-w6v7-w58j-pg5r"},{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"@theia/plugin-ext","purl":"pkg:npm/%40theia/plugin-ext","source":"GHSA-w6v7-w58j-pg5r"}],"prev":{"headline":"Code injection in Eclipse Equinox p2","id":"CVE-2021-41037"},"products":["@theia/plugin-ext"],"published":"2021-11-10","related":[{"cvss_score":9.8,"headline":"XML external entity in Eclipse Theia","id":"CVE-2021-34436","kev_date_added":null,"published":"2021-09-02"},{"cvss_score":9.6,"headline":"Cross-site Scripting (XSS) in Eclipse Theia","id":"CVE-2020-27224","kev_date_added":null,"published":"2021-02-24"},{"cvss_score":8.8,"headline":"File upload in Eclipse Theia","id":"CVE-2026-60009","kev_date_added":null,"published":"2026-08-05"},{"cvss_score":8.8,"headline":"Remote code execution in Eclipse Theia","id":"CVE-2021-34435","kev_date_added":null,"published":"2021-09-01"},{"cvss_score":8.4,"headline":"[Eclipse Theia] Indirect Prompt Injection via Adversarial Workspace File and Directory Names in AI Chat","id":"CVE-2026-44688","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":8.4,"headline":"[Eclipse Theia] Arbitrary Command Execution via Untrusted Workspace Task Definitions","id":"CVE-2026-44691","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":8.4,"headline":"[Eclipse Theia] Indirect Prompt Injection via Auto-Loaded Workspace Prompt Template Files in AI Chat","id":"CVE-2026-46580","kev_date_added":null,"published":"2026-06-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["The Eclipse Foundation"]},"summary":"Attackers can hijack Webview contents in Eclipse Theia via postMessage, potentially executing malicious code or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2021-41038/"}