# CVE-2021-41038: Improper Verification of Communication Channel in @theia/plugin-ext

> Attackers can hijack Webview contents in Eclipse Theia via postMessage, potentially executing malicious code or bypassing security controls.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w6v7-w58j-pg5r

## What is CVE-2021-41038?

CVE-2021-41038 is a medium-severity cross-site scripting vulnerability in @theia/plugin-ext, published on 10 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().

Weakness: CWE-940 (Improper Verification of Source of a Communication Channel)

## Which versions are affected by CVE-2021-41038?

2 open source packages ship an affected version, including @theia/plugin-ext. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@theia/plugin-ext` | npm | All versions | 1.18.0 |
| `@theia/plugin-ext` | npm | All versions | 1.18.0 |

Products: Eclipse Theia.

## How do I fix CVE-2021-41038?

Upgrade @theia/plugin-ext to 1.18.0 or later.

## Is CVE-2021-41038 being exploited?

There is no known exploitation of CVE-2021-41038 in the wild and no public exploit code.

## Other vulnerabilities in @theia/plugin-ext

- [CVE-2021-34436](https://insights.sbomify.com/CVE-2021-34436/): XML external entity in Eclipse Theia (critical 9.8)
- [CVE-2020-27224](https://insights.sbomify.com/CVE-2020-27224/): Cross-site Scripting (XSS) in Eclipse Theia (critical 9.6)
- [CVE-2026-60009](https://insights.sbomify.com/CVE-2026-60009/): File upload in Eclipse Theia (high 8.8)
- [CVE-2021-34435](https://insights.sbomify.com/CVE-2021-34435/): Remote code execution in Eclipse Theia (high 8.8)
- [CVE-2026-44688](https://insights.sbomify.com/CVE-2026-44688/): [Eclipse Theia] Indirect Prompt Injection via Adversarial Workspace File and Directory Names in AI Chat (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41038 and fix it if it is affected.

What it is: CVE-2021-41038 is a medium-severity cross-site scripting vulnerability in @theia/plugin-ext, published on 10 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41038 in the wild and no public exploit code.

Affected packages and fixed versions:
- @theia/plugin-ext (npm): affected all versions; fixed in 1.18.0
- @theia/plugin-ext (npm): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41038/ (Markdown: https://insights.sbomify.com/CVE-2021-41038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41038
- OSV: https://osv.dev/vulnerability/CVE-2021-41038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41038/
Summaries are generated and may contain mistakes; the official description above is the record.
