{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41055 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-41055 is a high-severity denial of service vulnerability in n/a, published on 11 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41055 and fix it if it is affected.\n\nWhat it is: CVE-2021-41055 is a high-severity denial of service vulnerability in n/a, published on 11 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41055 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41055/ (Markdown: https://insights.sbomify.com/CVE-2021-41055/index.md)","id":"CVE-2021-41055","markdown":"https://insights.sbomify.com/CVE-2021-41055/index.md","name":"CVE-2021-41055","record":{"aliases":["DEBIAN-CVE-2021-41055","DSA-5064-1","GHSA-r23x-224g-484r","MGASA-2022-0179","UBUNTU-CVE-2021-41055","openSUSE-SU-2024:11734-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"XMPP chat client","requires_auth":"none","summary":"Remote attackers can crash Gajim by sending a crafted XMPP Last Message Correction message in multi-user chats.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gajim","vendor":"gajim"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2021-41055","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":1,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2021-41057"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.3.3-1.1"],"introduced":["0"],"last_affected":[],"package":"gajim","purl":"pkg:rpm/opensuse/gajim\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11734-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2021-41054"},"products":["n/a"],"published":"2021-10-11","related":[{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2012-2086","kev_date_added":null,"published":"2012-11-23"},{"cvss_score":6.8,"headline":"Command injection in n/a","id":"CVE-2012-2085","kev_date_added":null,"published":"2012-08-28"},{"cvss_score":5.4,"headline":"Missing authorization in n/a","id":"CVE-2015-8688","kev_date_added":null,"published":"2016-01-15"},{"cvss_score":5.3,"headline":"Business logic in n/a","id":"CVE-2022-39835","kev_date_added":null,"published":"2022-09-27"},{"cvss_score":4.5,"headline":"Information disclosure in n/a","id":"CVE-2016-10376","kev_date_added":null,"published":"2017-05-28"},{"cvss_score":4.3,"headline":"Security feature bypass in n/a","id":"CVE-2012-5524","kev_date_added":null,"published":"2014-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can crash Gajim by sending a crafted XMPP Last Message Correction message in multi-user chats.","url":"https://insights.sbomify.com/CVE-2021-41055/"}