# CVE-2021-41078: Nameko Arbitrary code execution due to YAML deserialization

> Attackers can execute arbitrary code by tricking Nameko into deserializing a malicious configuration file.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6p52-jr3q-c94g, PYSEC-2021-383

## What is CVE-2021-41078?

CVE-2021-41078 is a high-severity unsafe deserialization vulnerability in n/a, published on 26 Oct 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Nameko through 2.13.0 can be tricked into performing arbitrary code execution when deserializing the config file.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-41078?

5 open source packages ship an affected version, including nameko. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nameko` | PyPI | All versions | 2.14.0 |
| `nameko` | PyPI | All versions | 2.14.0 |
| `nameko` | PyPI | All versions | 2.14.0 |
| `nameko` | PyPI | From 3.0.0rc0 | 3.0.0rc10 |
| `nameko` | PyPI | From 3.0.0rc0 | 3.0.0rc10 |

Products: Nameko Nameko.

## How do I fix CVE-2021-41078?

Upgrade nameko to a fixed version for your release line: 2.14.0 or 3.0.0rc10.

## Is CVE-2021-41078 being exploited?

There is no known exploitation of CVE-2021-41078 in the wild and no public exploit code.

Public exploit code:

- nameko Arbitrary code execution due to YAML deserialization (github_poc): https://github.com/s-index/CVE-2021-41078

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41078 and fix it if it is affected.

What it is: CVE-2021-41078 is a high-severity unsafe deserialization vulnerability in n/a, published on 26 Oct 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41078 in the wild and no public exploit code.

Affected packages and fixed versions:
- nameko (PyPI): affected all versions; fixed in 2.14.0
- nameko (PyPI): affected all versions; fixed in 2.14.0
- nameko (PyPI): affected all versions; fixed in 2.14.0
- nameko (PyPI): affected from 3.0.0rc0; fixed in 3.0.0rc10
- nameko (PyPI): affected from 3.0.0rc0; fixed in 3.0.0rc10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41078/ (Markdown: https://insights.sbomify.com/CVE-2021-41078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41078
- OSV: https://osv.dev/vulnerability/CVE-2021-41078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41078/
Summaries are generated and may contain mistakes; the official description above is the record.
