# CVE-2021-41083: CSRF Vulnerability in dada-mail 11.15.1 and below

> Attackers can hijack admin sessions via CSRF to take full control of mailing lists and change passwords, requiring users to upgrade.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-344m-p829-2r38

## What is CVE-2021-41083?

CVE-2021-41083 is a high-severity vulnerability in justingit dada-mail, published on 20 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Dada Mail is a web-based e-mail list management system. In affected versions a bad actor could give someone a carefully crafted web page via email, SMS, etc, that - when visited, allows them control of the list control panel as if the bad actor was logged in themselves. This includes changing any mailing list password, as well as the Dada Mail Root Password - which could effectively shut out actual list owners of the mailing list and allow the bad actor complete and unfettered control of your mailing list. This vulnerability also affects profile logins. For this vulnerability to work, the target of the bad actor would need to be logged into the list control panel themselves. This CSRF vulnerability in Dada Mail affects all versions of Dada Mail v11.15.1 and below. Although we know of no known CSRF exploits that have happened in the wild, this vulnerability has been confirmed by our testing, and by a third party. Users are advised to update to version 11.16.0.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-41083?

It affects 1 product.


Products: Dadamailproject Dada Mail.

## How do I fix CVE-2021-41083?

No fix has been published for CVE-2021-41083 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-41083 being exploited?

There is no known exploitation of CVE-2021-41083 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41083 and fix it if it is affected.

What it is: CVE-2021-41083 is a high-severity vulnerability in justingit dada-mail, published on 20 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41083 in the wild and no public exploit code.

Affected product: justingit dada-mail. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41083/ (Markdown: https://insights.sbomify.com/CVE-2021-41083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41083
- OSV: https://osv.dev/vulnerability/CVE-2021-41083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41083/
Summaries are generated and may contain mistakes; the official description above is the record.
