# CVE-2021-41086: Clipboard-based XSS in jsuites

> Attackers can execute arbitrary JavaScript via DOM-based XSS when users paste malicious clipboard content into the HTML editor.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qh7x-j4v8-qw5w

## What is CVE-2021-41086?

CVE-2021-41086 is a high-severity cross-site scripting vulnerability in jsuites, published on 21 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

jsuites is an open source collection of common required javascript web components. In affected versions users are subject to cross site scripting (XSS) attacks via clipboard content. jsuites is vulnerable to DOM based XSS if the user can be tricked into copying _anything_ from a malicious and pasting it into the html editor. This is because a part of the clipboard content is directly written to `innerHTML` allowing for javascript injection and thus XSS. Users are advised to update to version 4.9.11 to resolve.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-41086?

2 open source packages ship an affected version, including jsuites. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsuites` | npm | All versions | 4.9.11 |
| `jsuites` | npm | All versions | 4.9.11 |

Products: Jsuites Jsuites.

## How do I fix CVE-2021-41086?

Upgrade jsuites to 4.9.11 or later.

## Is CVE-2021-41086 being exploited?

There is no known exploitation of CVE-2021-41086 in the wild and no public exploit code.

## Other vulnerabilities in jsuites

- [CVE-2022-25979](https://insights.sbomify.com/CVE-2022-25979/): jSuites subect to Cross-site Scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41086 and fix it if it is affected.

What it is: CVE-2021-41086 is a high-severity cross-site scripting vulnerability in jsuites, published on 21 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41086 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsuites (npm): affected all versions; fixed in 4.9.11
- jsuites (npm): affected all versions; fixed in 4.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41086/ (Markdown: https://insights.sbomify.com/CVE-2021-41086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41086
- OSV: https://osv.dev/vulnerability/CVE-2021-41086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41086/
Summaries are generated and may contain mistakes; the official description above is the record.
