{"answers":{"affected":"3 open source packages ship an affected version, including github.com/elves/elvish. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41088 in the wild and no public exploit code.","fix":"Upgrade github.com/elves/elvish to 0.14.0 or later.","what":"CVE-2021-41088 is a high-severity code injection vulnerability in elves elvish, published on 23 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-41088 and fix it if it is affected.\n\nWhat it is: CVE-2021-41088 is a high-severity code injection vulnerability in elves elvish, published on 23 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-41088 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/elves/elvish (Go): affected all versions; fixed in 0.14.0\n- github.com/elves/elvish (Go): affected all versions; fixed in 0.14.0\n- github.com/elves/elvish (Go): affected all versions; fixed in 0.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41088/ (Markdown: https://insights.sbomify.com/CVE-2021-41088/index.md)","id":"CVE-2021-41088","markdown":"https://insights.sbomify.com/CVE-2021-41088/index.md","name":"CVE-2021-41088","record":{"aliases":["DEBIAN-CVE-2021-41088","GHSA-fpv6-f8jw-rc3r","GO-2022-0937","UBUNTU-CVE-2021-41088"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Elvish shell","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code on a user's machine if they visit a malicious site while the Elvish web UI backend is running.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"elvish","vendor":"elv"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-346","name":"Origin Validation Error"},{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"}],"description":"Elvish is a programming language and interactive shell, combined into one package. In versions prior to 0.14.0 Elvish's web UI backend (started by `elvish -web`) hosts an endpoint that allows executing the code sent from the web UI. The backend does not check the origin of requests correctly. As a result, if the user has the web UI backend open and visits a compromised or malicious website, the website can send arbitrary code to the endpoint in localhost. All Elvish releases from 0.14.0 onward no longer include the the web UI, although it is still possible for the user to build a version from source that includes the web UI. The issue can be patched for previous versions by removing the web UI (found in web, pkg/web or pkg/prog/web, depending on the exact version).","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote code execution via the web UI backend of Elvish","id":"CVE-2021-41088","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"`docker cp` allows unexpected chmod of host files","id":"CVE-2021-41089"},"packages":[{"ecosystem":"Go","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"github.com/elves/elvish","purl":null,"source":"GHSA-fpv6-f8jw-rc3r"},{"ecosystem":"Go","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"github.com/elves/elvish","purl":"pkg:golang/github.com/elves/elvish","source":"GHSA-fpv6-f8jw-rc3r"},{"ecosystem":"Go","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"github.com/elves/elvish","purl":"pkg:golang/github.com/elves/elvish","source":"GO-2022-0937"}],"prev":{"headline":"Improperly Implemented path matching for in-toto-golang","id":"CVE-2021-41087"},"products":["elvish"],"published":"2021-09-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["elves"]},"summary":"Attackers can execute arbitrary code on a user's machine if they visit a malicious site while the Elvish web UI backend is running.","url":"https://insights.sbomify.com/CVE-2021-41088/"}